A strange problem in a shortcut

I bought the David scores on Shortcuts and I’m very happy. I am learning a lot.
Here is a problem that I cannot solve: I made a nice shortcut to send messages to a group of people. When it runs it prompts me to go to google sheets and copy telephone numbers in a column (maybe there is a more automated way to do this but I don’t know it). The shortcut then parses the telephone numbers as recipients of the message. But it do not parse all the phone numbers. It always stops at a certain phone number. I squeezed in a quick look to see if it really has all the phone numbers in the clipboard and it has. So why doesn’t it parse all the numbers? I tried to do it manually and it worked without any problem.
Anybody here who has a clue what is wrong? I would be very glad for your help! Kind regards Per

Can you post a link to your Shortcut so that we can have a work through it and perhaps locate where the issue is? Without seeing the Shortcut, it is not really possible to track down the issue. Also, a look at a sample of your data would help.

Then just post the link in here and we can, hopefully, help out.

It would be useful for you to check if it stops at the same number or the same position if you reorder the list of numbers in the Google sheet column.

If it is at the same position, can you let us know how many lines that is? You may just have hit a limit.

If it is at the same number it is likely related to that number and how the shortcut is trying to deal with it. In such a case, can you share a cut down, suitably anonymised, version (e.g. the US always seem to use 555 in their fake TV show phone numbers) of the Google Sheet to test and investigate against?

Hi Tony! Thank you for your reply. Here is a link to the shortcut
And a picture off a part of the column with the phone numbers. It is a normal Google sheet and I copy the whole column with all empty spaces.
Have a nice weekend

Yes, it stopped at the same number every time, somewhere in the middle of the column, Line 55.
I tried to re-order the lines and it got even stranger: in quick look I see that it still has all the numbers but now it only parsed one number! Very awkward!
Sorry, but it is too big a job to anonymous the whole sheet. In my answer to Tony, there is a part of the column with anonymized values. Have a nice weekend

Exactly why I suggested a cut down version.

I only see redacted values, not anonymised values. Very different things. The first is a removal of data and the second is the replacement of data with equivalent data. i.e. it would be data that produces the same effect in the shortcut, as notes above.

The shortcut you shared isn’t processing the column in any way. It just dumps the clipboard into the text message. That to me even more strongly suggests that there’s likely an issue with the data that ends up on the clipboard that Shortcuts is then trying to parse.

If you cannot or will not share the data as described, other things you might wish to try yourself for diagnosing are:

  • What happens if you take a list of numbers from elsewhere - preferably an app that deals with plain rather than rich text?
  • What happens if you copy the list from Google Sheets elsewhere, and then in the shortcut copy it from that app instead?