Typescript type definition file for desktop IDEs?

I can now finally say that it’s finished! :smile:

I’ve fixed the bugs mentioned in my previous post and some more. Also thanks to @simonbs for fixing all the misspellings I’ve found and again for providing the Tern file!

2 Likes

Has someone else the same problem that sometimes in VS Code it forgets what type a variable is? It happens for me most of the time with this snippet of code at the top level scope (outside all curly brackets):

let fm = FileManager.iCloud();
fm.documentsDirectory();

If I hover with the mouse over

  • FileManager: no problem
  • iCloud: no problem
  • 2nd line fm: displays let fm: any meaning it doesn’t know its type…

Also in the 2nd line code completion doesn’t suggest documentsDirectory, only some common symbols…

As soon I wrap it in curly brackets, so it gets its own scope, then it suddenly works…

I’ve tried it in different files in different locations and it only happens in the Scriptable folder in the iCloud Drive folder (not Shortcuts folder or any other). It even works in a subfolder in the Scriptable folder, but not directly inside it. Sometimes. Sometimes it works, sometimes not. But consistently. If it worked once, it will work every time and vice versa.

I wanted to file a bug report in the VSCode Github repo, but I hope its not a problem with VS Code… who knows.

Does someone have the same issue? Btw, I’m on Windows 10.

I’ve updated the project for Scriptable 1.4! And I’ve added tags for Scriptable 1.3 and 1.4

1 Like