Two Shortcuts ?s that I'm embarrassed to ask

because at one point I was able to do these. :slight_smile:

  1. I have a Shortcut that takes some pics and manipulates them, then sends them elsewhere. When I run it, I choose the pics and it works fine. But I want to run it from the Photos app, I select a few pics and share them to the Shortcut via the share sheet. But it ignores my earlier selections and just prompts me for the pic s to use. What am I doing wrong? I swear I’ve solved this before but can’t remember.

  2. When I open an existing Shortcut and add a new step, I can’t consistently get the line between that step and the ones before and after it. What am I missing here?

Thanks in advance!!!

  1. Will be to do with shortcut input. If you share I’m sure the collective can show you a revised version that will work for both.
  2. That’s working right. You only get the line when the step is actively using the output of the previous step. That’s what that line means. No active use means no line.