Speak Text doesn't. Sort of

I have a shortcut that ends with speak text and then copy to clipboard.

If I run it via “Hey siri” it displays the results on screen on my phone.

If I run it via the shortcuts app, it speaks the text.

Obviously, I want it to speak the text all the time, which it used to do. I am up-to-date on iOS and Shortcuts.

You could add a Continue Shortcut in App step at the start of your Shortcut to force the Shortcut to run in the App and therefore speak the text, no matter where it is invoked from. Not an elegant way of the Shortcut running, but it should get the speech that you want.

Also, are you just using the Show Result action to produce your results or have you got an actual Speak Text action in there, which should force the speech rather than it making a decision on how to “display” the results.

Otherwise, can you post the Shortcut here so we can have a look and see if anything else jumps out?

The last three actions in the script are:

When run from Siri the results of the clipboard are shown on the screen (Why? I have no idea) and the speech part is ignored, but the list is on the clipboard. When run from the Shortcuts app the speech is done and nothing is displayed, but the list of movies is in the clipboard.

The point is to be able to run this via Hey Siri and hear the list, so having it forced to run in the app is not helpful.

OK, more info. The speak text does not fire if I use the side button or tap the Siri bubble on the screen. It DOES fire if I call to the phone across the room and haven’; touched it in anyway to invoke Siri.

So, this appears to be an iOS 12 “feature” and not a Shortcuts issue.


Just as another thought, have you got Siri set to always give voice feedback? Settings > Siri & Search > Voice Feedback > Always. From your last update, it sounds like you may have it set to Hands-Free Only.

1 Like

Well, I wonder how THAT happened. Thanks!

1 Like