Shortcuts Email Authentication Failing

I had to delete and reinstall the Shortcuts app on my iPad recently. Ever since, I’ve had a weird bug that prevents me from enabling my email account to the stock “send email action.” I’m getting a pop up that said authentication has failed. However, when I delete and try to reconnect my account in my phone, everything runs as normal and I’m able to sync the “send email” action to each of my accounts.

Anyone have any experience with this bug?

I’ve no experience with this error as far as I recall, but I have a few questions if that’s okay? Not all would be applicable in all circumstances, but hopefully it’ll help clarify what’s going on.

  1. When does the error message pop up? When you add an email action, when the shortcut runs and tries to send the mail, etc.
  2. Can you share the exact wording of the error message?
  3. What accounts to you have listed in the settings here, and are the settings correct?
  4. Who is your email provider?
  5. Does your account use two factor authentication, or app specific passwords?
  6. Presumably you can still send emails directly from your iPad email app of choice … which is the stock Mail app?
  7. Have you tried reauthenticating at the OS level. E.g. Changing the password, or removing and reading your account.

Hopefully something above will give us the clue we need to take the next step towards resolving the issue.

1 Like

Thanks for your questions!

  1. The error message pops up any time I try to authenticate any email address within the Shortcuts app, regardless of the service provider.
  2. The exact wording is “Authentication failed. The email address or password you entered was incorrect. If you have two factor authentication enabled, you need to create an app specific password.” The password is most assuredly correct, and I don’t have two factor enabled for this particular account.
  3. I don’t have any accounts enabled, as the authentication error is preventing me from enabling them.
  4. I’m trying to use a gmail account and a business account hosted through GSuite
  5. No.
  6. Yes I can still send emails through both mail.app and Airmail on all of my devices.
  7. I haven’t tried changing my password just yet. I’m able to authenticate on my iPhone, just not my iPad, which has led me to believe this is an iPad only bug. (I’ve submitted the proper bug reports.)

Additional information: on my gmail account, if I have the shortcut set to “show compose sheet,” I am able to send an email fine, but when compose sheet is turned off, I receive a server error. With my GSuite account, I am unable to send email regardless of the compose sheet setting.

Thanks again for responding!

Other than the password change, which I’m definitely not 100% convinced would work for this case, all that I can think to try based on the above is removing the e-mail accounts at the OS level; then adding one back, check Shortcuts, and then add the second back and check again. This is purely on the basis that it would clear everything out, and reinitialise it such that Shortcuts can access it afresh. Certainly, nothing’s jumping out at me otherwise from the answers you’ve given.

Thanks for your help! I’ll give it a shot and let you know how it goes.

Edit: Removed my account at the system level, and it still won’t authenticate in Shortcuts, unfortunately.