Shortcut not able to find screenshots

Trying to learn Shortcuts so I implemented a simple one from Matthew Cassinelli to delete unplanned screenshots (

I have it implemented as shown but when I run the shortcut it returns an error saying
“The file doesn’t exist.
Shortcuts couldn’t find the requested items in your photo library.”
When I go to the photos app and search for screenshots I get a list of 60 screenshots.
I have granted Shortcuts permission to access my photos so what am I missing?

Can you share your Shortcut just so we can double check exactly what it is doing?

Also, can you confirm that the screenshots are all in your camera roll - which is where the Get Latest Screenshots action is looking.

I already had a simplified version of this (without the picker). I’ve added the picker and run it. Works for me. Feel free to download my version and see if you can get it working

Hopefully the link below will get you what you need.

W.r.t. the camera roll I do not see anything in the photos app that indicates what is in the camera roll, so I am not certain how to get to it without a bit more research (will investigate next).

The 60 screen shots I mentioned are identified when I search for screenshots in the Photos app.

For what it is worth, when I create a screen shot and save it the message iOS provides asks “Save to Photos”, and the photos app is where I find them. So that is why I’ve made this assumption.

Thanks for the help.

When I downloaded this I got a different Shortcut (an out of office shortcut). I’ve heard Rosemary and Macsparky mention issues with the Shortcuts app keeping shortcuts organized and synced x perhaps that also impacts sharing?

No. It was probably me. I’d just posted a different shortcut and mustn’t have c&p the correct link. Try this

Finally tested yours and it works fine. I have updated to iOS 12.1 and the latest version of Short its and my shortcut works now.
My original version is identical to yours except for the number of screenshots. I played with various values originally with no luck. Only thing I didn’t try was creating a new version to see if something was corrupted.

This was my first real experience with this forum it is nice to get folks who are willing to spend a few minutes to help out. Thanks much for your help!