PDF actions in Shortcuts broken on 17.1

Maybe it’s the Quick Look that freezes. Can you try inserting “Go to Home Screen” right above it?

1 Like

I’m noticing the exact same thing, but the PDF actions appear to not function when called from a Share Sheet. I modified your sample above, and altered it so that it there’s no input, it just copies what’s on the clipboard. If I copy in some text, and run this shortcut within the editor, the PDF display works fine. However, if I select some text anywhere and run this from the share sheet, it fails. I’m on iPadOS/iOS 17.1.2 and have noticed this everywhere.

@gluebyte That sidesteps the bug somehow! Thank you, this is a huge help and unblocks me. Any idea why sending the shortcut to the Home Screen would work in this instance?

@joeybaumgartner Looks like you’re correct, this is a bug specific to the share sheet context. I’ll add this to my report to Apple.

Really appreciate the help from both of you!

No idea how/why the workaround works, I just tried different things to get around. BTW the Wait action also seems to work.

1 Like

It’s another instance of this bug (FB13310942):

The share sheet is the first “dialog”, and the Quick Look is the second. So it’s not specific to the share sheet.

If you’re in an iPad in dark mode, you can probably see a 1px light line at the top center of the screen. And in both iPhones and iPads you’ll see the swipe bar at the bottom disappear. If you swipe up from the bottom the shortcut will stop and the swipe bar will reappear.

That’s very enlightening. Seems like you first reported this in late October, which I think tracks with the bug first appearing in iOS 17.1, right?

Correct. I sent the feedback report as soon as I could, because I saw it becoming a particularly frustrating issue (it affects Quick Look, the most common debugging technique :sweat_smile:).

Unfortunately it still happens in iOS 17.2 RC :sweat:

Yes I see it on the 17.2 RC too. Let’s hope it’s on deck for 17.3.

New detail. When the shortcut is stuck, the swipe bar, normally at the bottom, end up below the notch :exploding_head:

1 Like

Yes, what you see on iPad at the top is also the bottom of the home indicator🫠

It appears that app switching (Go to Home Screen or Open App) is the only reliable workaround for that because the Wait action fails sometimes.

1 Like

You’re right :exploding_head: You can even move it a bit up and down touching at the bottom :woozy_face:

It even appears with Stage Manager on and non-fullscreen windows :sob:

Great tip opening an app instead of a “Wait” as workaround. I’m using “Open Shortcuts” now before any 2nd dialog. It hasn’t failed me once, and it doesn’t kick me out of the editor when debugging :partying_face:

iOS 17.3 beta 1 is out. Has anyone seen if this issue is fixed? (Or if there are new issues with shortcuts?)

Still an issue in 17.3 beta 1 :sweat:

I encountered this bug today when creating a shortcut that scans a document with the camera and then has a few options for what to do with the document. I found that if I save to a specific file path (which also names the file), it works fine. If I try to name the file and then do anything with it (share sheet, ask where to save, etc.), the shortcut gets stuck.

Another clue that told me this was a bug, and not just me failing to write the shortcut properly, is that the “Save As” screen is off to the side of iPhone screen, completely useless with no way to actually save the file.

Okay, so now I know this shortcut is limited until the bug is fixed. :crossed_fingers:

1 Like

Still an issue in today’s iOS 17.3 beta 2 :sweat:

This might have been obvious to others but I just realized that there’s no Go to Home Screen equivalent in Shortcuts for macOS. That means that for shortcuts where I’ve used that action to workaround this bug, those shortcuts are now effectively broken on the Mac.

Obviously Apple really has to fix this, but I’m wondering if anyone has had luck with a different workaround/different action that is more Mac-friendly?

Wrap the action in an “If OS is not macOS”?

Brilliant, thank you, that worked. I hadn’t used the If action in that way before so I had to Google it, and I found this handy animation that shows how that’s done.

Good news! FB13310942 seems to be fixed in iOS 17.4 beta 4 :partying_face::tada:

I have to remove sooo many Open App actions from my shortcuts! :sweat_smile:

1 Like

Hallelujah! Happy to have to do the same.