iOS 14 Public Beta 8 does not fix Shortcuts input box bug

The bug where the cursor and keyboard not automatically appearing in the Shortcuts Ask For Input action now is fixed in the latest beta release.


How many inputs do you have? For me, only for the first 3/5 in one Shortcut the keyboard comes up. :thinking:

Its one to log the data from my not-smart-scale.

You are right. I put in 5 Ask For Input actions and after the second one the keyboard stopped popping up. I’ll report it to Feedback.

1 Like

Can you check please if the keyboard is every time shown, if you enter only integers instead of float numbers. For me it works fine then. If i enter float numbers the last “Ask for input” shows no keyboard.

Nope. I changed all the inputs to receive numbers instead of text. Still around the 3rd or 4th input the keyboard stops activating and you have to tap in the input box to get the keyboard back.

Just tried the inputs in Beta 6. Keyboard still hangs up after the 3rd input action.

same for me, so more feedback to write

1 Like

Just downloaded Beta 7. The input action still stops invoking the keyboard after the 3rd or 4th time. I reported the bug again to Feedback. #FB8621736

1 Like

Here is my Test Input Shortcut that I use to test this bug. It’s just 6 Ask For Input actions. By about the 3rd or 4th action the keyboard stops responding. I also notice that if you use a Shortcut that only has one Ask For Input, if you run that Shortcut 3 or 4 times in a row the keyboard will fail to pop up.

Beta 8 still hasn’t fixed the input bug.

Here is my test Input Shortcut. If anyone having the 4th input activate the keyboard let me know.

And if it does fail please do a Feedback on it.

On IOS 14.2 beta 2. Still not fixed Add Input bug. I am beginning to think Shortcuts bugs have been put on the back burner.

IOS 14.2 GM. Still does not fix the keyboard problem. I begin to think this issue does not only occur in Shortcuts but is system wide with the keyboard at times not initiating when it should.

I don’t report anymore, looks like Apple is not interested in fixing this. :frowning:

Yeah. I gave up too.

I think it’s fixed with iOS 14.3 beta 3!


I am afraid it is not. :disappointed:

I found a workaround!

It appears that the keyboard pops up again, when there is a slight delay between the Ask for Input actions. In my tests it was sufficient to simply insert an empty Repeat loop with repeating it only once. I’ve put no action inside the loop. I had to insert the loop before every Ask for Input action starting after the 3rd one and the numeric keyboard reliably popped up again.

1 Like

Well, the workaround hasn’t worked when running from the widget, but increasing the loop count to 100 fixes it. At least it seams to…

Are you using the 14.3 beta?

No. iOS 14.2.

But today it didn’t work in the widget. I will try it with a simple Wait action set to one second. If this still doesn’t work, then I’m out of ideas.