Does anyone else have this Drafts Bug?

Can someone replicated my steps below and tell me if you get the same result?

I created a Draft on my watch, it synced all the way through to my Mac. I changed it on the Mac, it only synced as far as my iPhone. My watch doesn’t get the updated draft. I sent off a support request, but I wanted to verify that someone else has this bug as well.



1 Like

I don’t have Drafts, but I have some sync problems with calendar events on my watch. Sometimes a recurring event, created on my iPhone, doesn’t show up on the watch, sometimes also an event from a subscribed calendar.
Maybe this is a bug in iOS/WatchOS…

Following the flow you described, everything synched immediately for me.

Current beta on all devices


1 Like

It turns out it’s just a major delay between the phone and the watch for some reason. It showed up eventually. It could have been my phone being busy I suppose. I do make it work very hard, so I guess I should give it a break once in a while! :slight_smile: Thanks to those that replied!

Jep - something is not good. My first sync’s worked fine, but after editing the file once, it was not synced…

1 Like