Date format woes with Workflow

Hi automators all,

I’m having trouble with a Workflow sequence I’ve adapted from a @MacSparky Cmd-D 2017 presentation ( ). I refer to the “rename and save a PDF” workflow David demonstrates in the talk.

The bits I’ve tacked on work fine when generating the new file name, but I can’t get the date to show me my preferred reverse numerical format (David explains date format options at around timestamp 22:51) . I’ve tried the ISO 8601 and a custom format that works for me in any other text replacement app (YYYY-MM-DD). The resulting file name ALWAYS shows the date as a text short date and time eg “3 Sep 2018 at 20:48“. This is despite having the “time” option turned off and no matter what date format option I choose.

If someone can tell me how to share a Workflow sequence on the forum, I’ll gladly put it up for your inspection and critique. (Not sure if this is correct: )

How can I solve this?

Have you tried yyyy-mm-dd?

That did it in your workflow on my iPad…

I think this simplified version should do what you want. I’ve reworked it a bit using magic variables.

The date stamp is set using the current date, formatting with the date format set as custom, and specified as ‘yyyy-MM-dd’.

Yes, tried that and it didnt work


I was trying to work through from a very basic level, following along with David, so that I could get to grips with the app. I don’t understand how to use magic variables, you see.

I’d like to know what’s going wrong with my workflow sequence to create a more solid base for myself as I try to gain a greater understanding of the logic behind everything.

Couple ways around this. When you are setting the file name, you are using the original date variable. Change the variable to “formatted date” and it should work.

Or, you can skip the formatting step early on and instead format the date when you set the file name. Pressing on date brings up a format option

Fundamentally, you have the wrong date format string (the elements are case sensitive and have differing meanings), and you have two variables called “Date”. One that you defined and one that the system defines. You have selected the former rather than the latter in the filename.

Hope that clarifies things.

Bingo! Thanks so much, Kevin. It now works as envisaged. The screenshots were very helpful.

I’ll learn, … slowly … eventually :sweat_smile:

Thanks, Sylumer.

I’ll have to keep studying. :laughing: