Adding reminders from Shortcuts in iOS13 is 30 minutes off

Anyone else experiencing this issue? For me this is happening in the most basic form:

  1. Add a reminder with an alert at a specific time.
  2. Reminder will be a half hour off.

Just tested. Time is a match for me. No deviation.

Interesting. Wonder what it could be then.

A few random thoughts would be:

  1. Have you updated anything recently?
  2. Have you experimented with time zones at all lately?
  3. Are you syncing reminders with any non-Apple service?
  4. Have you tried a reboot?
  5. How do the reminders look on another device, or maybe

I wouldn’t post if I didn’t try the basics. I just updated to 13 today. Created a 1 action shortcut to add a reminder for testing. It’s a half hour off. I tried to add the reminder several different ways. by supplying it with text or formatted dates first, but even it the simplest form, it’s 30 minutes off. But, seeing as it’s not doing it to you, I guess it’s me.

Well that you updated to 13 today might well be relevant in the comparison given I’m on 12 on my devices. I’m avoiding having mismatched reminders databases across devices. Only the update for iPhones and iPod is currently available, so I’m delaying my updates for a little while.

From your response am I right to infer that it is the actual setting of the value and not the display of the value as it is confirmed as consistent across all locations (ref. no. 5 above).

The basics for one person aren’t necessarily the same for the next, or a prerequisite to posting a question, so please keep in mind I’m just trying to be helpful, and to get a feel for the underlying issue and cause as best I can. That means ensuring that all the info is set out to narrow things down.

I forgot to put iOS13 in the title. It’s been correct in iOS 12 previously. It’s correct though in

Is this happening to anyone else on iOS 13?

can you share the shortcut that is producing this result? Just to see whether it produces the same result on my iOS 13 device?

There’s only 1 step. Add the “Add Reminders” action and set the values with an alert time. Mine is always 30 minutes off.

Just tested it, mine are fine.

Only thing other than a bug I can think of is a timezone issue?
What is your timezone priority setting? Maybe they interfere?
I would not think so, as they impact calendar entries mostly.
But hey, you never know

Copied your shortcut exactly. Don’t get the 30 minutes bug. Interesting.

Running 13.1 beta on iPad with no problem.

Didn’t know .1 was released. That fixed it. Thanks everyone!

1 Like